OpenLP 2.0.4 "Correct Caleb" Released

OpenLP 2.0.4

Welcome to another bugfix release of OpenLP 2.0. This is a further release in the stable 2.0 series. While it might not look like much, we're hoping that this release will make everyone's lives just a little bit easier.

Bugs fixed in this release:

  • #1117098: Transparent theme is white on Mac OSX
  • #1154467: Web download bible db's getting locked
  • #1173749: Songs with mismatching formatting tags still throw an exception
  • #1252477: Changing theme on bible settings tab causes an error when saving service
  • #1012110: pptviewlib does not accept unicode filename
  • #1199639: Formatting tags opened and closed in different verses throw an exception
  • #1206886: HTTP Server gets deleted
  • #1222534: KeyError when "Allow presentation application to be overridden" and Spanish language is selected
  • #1223841: Transition does not work if texts are the same
  • #1225763: Replacing background with video unblank screen even if "Blanked to Theme"
  • #1247661: Cannot restore OpenLP after minimising on OSX
  • #1251437: BibleGateway importer crashes on non unicode urls
  • #1258634: TypeError when saving service from previous versions with notes
  • #1259606: Clicking Verse Button doesn't alter live slide
  • #1266271: Output display returns after pressing esc when looping slides
  • #1157938: "Alt + Tab" = some pixelated icons and missing icons
  • #1211049: Can no long download bible verses
  • #1216234: Layout style has not effect when using a second bible
  • #1240942: Troubleshooting guide is outdated
  • #1265368: [regression] Traceback in web remote
  • #1163874: Add Slovak bible to First Run Wizard. (SK - Katolický (Písmo Sväté))

Stay dressed for action and keep your lamps burning, and be like men who are waiting for their master to come home from the wedding feast, so that they may open the door to him at once when he comes and knocks.

Luke 12:35-36 (ESV)

Comments

Hi, I tried to use the mac download twice but each time it is a binary which my fully up to date mac says is damaged and can't run.

I'm sticking with 2.0.3 for now...